3笔记本下安装Nvidia显卡驱动,在Debian上安装最新NVIDIA显卡驱动

笔记本安装SUSE10.3,显卡为N卡Nvidia
GeForce Go 7300,如下面英文安装方法安装openSUSE 10.3
-AMD64,按提示完成安装

我的测试环境:Debian Testing

openSUSE 10.3-AMD64

测试硬件:P4 3.0(HT) 512M内存 160G Sata硬盘 Nvidia 6200 TC显卡

It is recommended to use YaST for installation of the NVIDIA
driver. There are several reasons for this. First, it’s
simple. Second, and this is the most important one, you won’t need to
recompile the nvidia kernel module after a kernel update.

1、安装NVIDIA显卡驱动前的准备工作

Update your Kernel via YOU (YaST Online Update). Use

$ su

  YaST -> Software -> Installation Source -> Add

$ apt-get install build-essential pkg-config xserver-xorg-dev

  Protocol: HTTP
  Server Name: : download.nvidia.com
  Directory on Server: /opensuse/10.3

$ uname -r

to add the NVIDIA ftp server as additional installation source.
Now use

$ apt-get install linux-headers-你 执行uname
-r的结果(要是自己编译内核,安装编译内核成功时的Deb包就行了)

  YaST -> Software -> Software Management

2、安装NVIDIA显卡驱动

to install the NVIDIA driver. Select the following packages:

到页面下载相应的驱动

  x11-video-nvidiaG01
  nvidia-gfxG01-kmp-default

注意:Latest Version、Latest Legacy GPU version (1.0-71xx
series)和Latest Legacy GPU version (1.0-96xx
series)是不同的,特别是老显卡,请注意选择版本!

1-Click-install:

详细请看:

If you own one of the following NVIDIA graphics chips

What is a Legacy GPU?

  0x0110 GeForce2 MX/MX 400
  0x0111 GeForce2 MX 100/200
  0x0112 GeForce2 Go
  0x0113 Quadro2 MXR/EX/Go
  0x0170 GeForce4 MX 460
  0x0171 GeForce4 MX 440
  0x0172 GeForce4 MX 420
  0x0173 GeForce4 MX 440-SE
  0x0174 GeForce4 440 Go
  0x0175 GeForce4 420 Go
  0x0176 GeForce4 420 Go 32M
  0x0177 GeForce4 460 Go
  0x0178 Quadro4 550 XGL
  0x0179 GeForce4 440 Go 64M
  0x017A Quadro NVS
  0x017C Quadro4 500 GoGL
  0x017D GeForce4 410 Go 16M
  0x0181 GeForce4 MX 440 with AGP8X
  0x0182 GeForce4 MX 440SE with AGP8X
  0x0183 GeForce4 MX 420 with AGP8X
  0x0185 GeForce4 MX 4000
  0x0188 Quadro4 580 XGL
  0x018A Quadro NVS 280 SD
  0x018B Quadro4 380 XGL
  0x018C Quadro NVS 50 PCI
  0x01A0 GeForce2 Integrated GPU
  0x01F0 GeForce4 MX Integrated GPU
  0x0200 GeForce3
  0x0201 GeForce3 Ti 200
  0x0202 GeForce3 Ti 500
  0x0203 Quadro DCC
  0x0250 GeForce4 Ti 4600
  0x0251 GeForce4 Ti 4400
  0x0253 GeForce4 Ti 4200
  0x0258 Quadro4 900 XGL
  0x0259 Quadro4 750 XGL
  0x025B Quadro4 700 XGL
  0x0280 GeForce4 Ti 4800
  0x0281 GeForce4 Ti 4200 with AGP8X
  0x0282 GeForce4 Ti 4800 SE
  0x0286 GeForce4 4200 Go
  0x0288 Quadro4 980 XGL
  0x0289 Quadro4 780 XGL
  0x028C Quadro4 700 GoGL

The following GPUs are no longer supported in the regular NVIDIA
Unified UNIX Graphics Driver. Instead, these GPUs will continue to be
supported through special “Legacy GPU” drivers that will be updated
periodically to add support for new versions of Linux system components
(e.g., new Linux kernels, new versions of the X server, etc).

select instead the packages:

There are presently two Legacy GPU driver series. The 1.0-71xx series
supports TNT, TNT2, GeForce 256, and GeForce2 GPUs. The 1.0-96xx series
supports GeForce2 MX, GeForce3, GeForce4, and Quadro4 GPUs. For a
complete list of the GPUs supported in each of the Legacy GPU driver
series, see the lists below.

发表评论

电子邮件地址不会被公开。 必填项已用*标注